Wednesday 23 July 2008

ISDN backup link configuration and EIGRP redistribution


Had a few days with ISDN backup link setup on a new Cisco 2821 router with 12.4(7) IOS.

It was quite easy to dump all the old configuration from old Cisco 4000 router (with IOS 11.2) with a few change - something like define the isdn switch-type since the new IOS doesn't have default value.


aaa authentication ppp default local
!
username southrouter password 7 xxxxxxxxxx
!
interface BRI1/3
description ISDN Backup to South Router
no ip address
encapsulation ppp
dialer pool-member 8
isdn switch-type basic-net3
isdn point-to-point-setup
no fair-queue
ppp authentication chap
!
interface Dialer8
description Link to South Router
bandwidth 1
ip address s.s.s.s.2 255.255.255.0
encapsulation ppp
delay 10000000
dialer pool 8
dialer remote-name southrouter
dialer idle-timeout 300
dialer enable-timeout 2
dialer string 5555555
dialer-group 10
ppp authentication chap
!
access-list 100 deny ip any host 255.255.255.255
access-list 100 deny eigrp any any
access-list 100 deny udp any any eq snmptrap
access-list 100 deny udp any any eq syslog
access-list 100 deny udp any any eq ntp
access-list 100 permit ip any any
dialer-list 10 protocol ip list 100
!



So far so good, ping the other end and link was brought up. Well done! the next step is to make a float static route and inject into eigrp. So I typed in

router eigrp 20
redistribute static


And another fake floating static route with the real one:
ip route 10.200.10.0 255.255.255.0 s.s.s.1 210

But in the core switch, this route didn't show up and neither with other real routes.

After about one hour's internet search, I found something intersting here:

When redistributing between different routing protocols, the default-metric com-mand must be configured. When one routing protocol is being redistributed into another, the router doesn't have a way to translate the routing metric from one routing protocol into another. The default-metric command is used so that the network administrator can manually initialize the routing metric during route redistribution.
(from: http://www.ciscopress.com/articles/article.asp?p=27839&seqNum=7)

Default Setting for EIGRP "default-metric" Command:

Only connected routes can be redistributed without a default metric. The metric of redistributed connected routes is set to 0.

(http://www.cisco.com/en/US/docs/ios/12_3t/ip_route/command/reference/ip2_c1gt.html#wp1094645)




After I typed in:
router eigrp 20
default-metric 64 20 255 1 1500

Guess what happened, the floating route is in RIB of core switch now!


TO BE CONTINUED...

No comments: